【IT168 专稿】
1、静态NAT配置
命令:ip nat inside source static local-ip global-ip
local-ip:内部网络中的私有IP;global-ip:内部全局IP。
实例:
ip nat inside source static 10.1.1.1 202.11.21.154
interface Ethernet 0
ip address 10.1.1.10 255.255.255.0
ip nat inside
interface Serial 0
ip address 172.16.2.1 255.255.255.0
ip nat outside
功效:通过接口Ethernet0发往外部网络的数据流,在经过Serial0接口时,如果源地址是10.1.1.1,源地址将被转换为202.11.21.154。
2、动态NAT配置
命令:
ip nat pool pool-name start-ip end-ip { netmask netmask | prefix-length prefix-length }[type rotary]
ip nat inside source list access-list-number pool pool-name
注释:pool-name: 地址集的名称;start-ip:地址集的起始IP;end-ip:地址集的终止IP;netmask:网络掩码;prefix-length:网络位的长度;type rotary:用于表明地址集中的地址是真实的内部主机地址,地址转换时将循环使用地址集中的地址,用于TCP负载均衡。
实例:
access-list 1 permit 10.1.1.0 0.0.0.255
ip nat pool dyn-nat 192.168.2.1 192.168.2.254 netmask 255.255.255.0
ip nat inside source list 1 pool dyn-nat
interface Ethernet 0
ip address 10.1.1.10 255.255.255.0
ip nat inside
interface Serial 0
ip address 172.16.2.1 255.255.255.0
ip nat outside
功效:通过接口Ethernet0发往外部网络的数据流,在经过Serial0接口时,如果源地址在网络10.1.1.0内,源地址将被动态转换为192.168.2.0网络内的任意一个IP地址。
3、负载均衡配置
命令:
ip nat pool pool-name start-ip end-ip { netmask netmask | prefix-length prefix-length } type rotary
ip nat inside destination list access-list-number pool pool-name
实例:
access-list 2 permit 10.1.1.127
ip nat pool real-host 10.1.1.1 10.1.1.3 prefix-length 24 type rotary
ip nat inside destination list 2 pool real-host
interface Ethernet 0
ip address 10.1.1.254 255.255.255.0
ip nat inside
interface Serial 0
ip address 192.168.1.129 255.255.255.0
ip nat outside
功效:外部主机通过Serial0接口访问内部虚拟服务器,Cisco IOS防火墙将动态在10.1.1.1~10.1.1.3之间选择一个合适的服务器进行转发,从而实现负载均衡。
4、网络地址交迭配置
任务:实现网络地址交迭,避免地址冲突。
步骤:
access-list 1 permit 10.1.1.0 0.0.0.255
ip nat pool net-2 192.2.2.1 192.2.2.254 prefix-length 24
ip nat pool net-10 10.0.1.1 10.0.1.254 prefix-length 24
ip nat inside source list 1 pool net-2
ip nat outside source list 1 pool net-10
interface Serial10/0
ip address 172.69.232.182 255.255.255.240
ip nat outside
interface Ethernet0
ip address 10.1.1.254 255.255.255.0
ip nat inside